技術

[Xcode] iOSソフトウェアアップデート後に、Could not locate device support files.

投稿日:

こんにちは。たなかです。

Xcodeで開発中に以下のエラーにぶつかりました。

エラー内容

This iPhone X (model a1865, a1901, a1902, a1903) is running ios 12.1 (16b92), which may not be supported by this version of xcode.

 

先日iPhoneのソフトウェアアップデート(12.1)が来ていたので、特に気にせずそのまま最新に更新してしまったのですが、Xcodeの方はまだ12.1に対応できていないみたいです。おいおい遅れずについてこいよー。

解決方法

調べてたらいくつかやり方があるみたいですが、今回以下の方法で解決しました。

iPhoneOSDeviceSupport にアクセス

https://github.com/filsv/iPhoneOSDeviceSupport からお求めのバージョンzipファイルを取得します。今回は12.1をダウンロード。

②展開してローカルに配置

ダウンロードしてきたファイルを展開して、

/Library/Developer/Xcode/iOS DeviceSupport/ 配下に配置します。

③Xcodeを再起動

ファイルを配置したら起動していたXcodeを一度再起動。

再びbuildを走らせるとエラーが出なくなりました! やったぜ(やったぜ)。

 

短いですが今回はここまで。

-技術
-

執筆者:


comment

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください

関連記事

no image

rubyでシンボリックリンクを作成する

rubyでシンボリックリンクを作る機会がありました。 どちらも、srcへのシンボ …

no image

【Rails】deviseを日本語化する

こんばんは railsでログイン機能を作る時にdeviseを使う方は多いのではな …

【Alexa Skill】ビックリするなかれ (Unsupported Directive)

どうも中田です。 みなさんAlexa使ってます?Alexaスキル作ってます? 今 …

no image

【gem/bundle】あんたたち一体どういう関係なのよ!!

どうも中田です。 今回はgemとbundleの話。 前置き よくあるgemの説明 …

no image

CSSのpositionで要素を真ん中寄せにする(JS不要)

positionを使って要素を真ん中寄せにする時は、transform: tra …